Back to overview
Downtime
App outage
Feb 04 at 01:00pm CET
Affected services
Herodesk app
Resolved
Feb 04 at 01:20pm CET
The problem has been identified and resolved. We're sorry for any inconvenience this has caused.
Affected services
Herodesk app
Created
Feb 04 at 01:00pm CET
We're currently seeing a system outage that is making Herodesk unavailable. We are investigating and will update ASAP.
Affected services
Herodesk app