Back to overview
Degraded

Degraded performance

May 28, 2026 at 5:05am UTC
Affected services
Inbound e-mail

Resolved
May 28, 2026 at 8:00am UTC

All e-mails have now been imported, and normal operations have resumed. No e-mails have been lost. We're sorry about the inconvenience. We expect the post-mortem to reveal the underlying cause, enabling us to add increased surveillance in the future, if not remove the root cause of the issue entirely.

Updated
May 28, 2026 at 6:15am UTC

Import of e-mails is now in process. There's a big queue, so it will take some time before all is imported. They are starting to flow into Herodesk inboxes now.

Created
May 28, 2026 at 5:05am UTC

Import of e-mails has been delayed since May 27th at approx. 10 AM. No e-mails are lost, but the import of new e-mails to Herodesk is delayed.